Добавлен новый документ

Узнаем как внедрять любые типы документов в файл Excel для возможности открытия документов непосредственно из книги.

Приветствую всех, дорогие читатели блога TutorExcel.Ru.

  • Для тех кто больше предпочитает формат видео — приятного просмотра, для любителей же текста приятного чтения.
  • Давайте для начала подумаем для чего вообще вставка файла в Excel может быть полезна?

Помимо работы с данными внутри книги Excel иногда бывает необходимо к документу приложить какие-либо внешние данные в виде дополнительного файла. Так как вместо отдельного хранения файлов зачастую удобней внедрить их все в документ.

Это позволяет получить более быстрый доступ к внешним файлам, повышает удобство просмотра и работы с файлом, в общем и целом в определенных случаях весьма полезный инструмент.

Как внедрить документ в Excel?

Стоить отметить, что инструментом внедрения пользуются достаточно редко, поэтому нужную вкладку не так-то просто найти.
Переходим во вкладку Вставка -> Текст -> Объект:

Добавлен новый документ

Далее щелкаем мышкой по кнопке Объект и перед нами появляется всплывающее окно с настройками вставки:

Добавлен новый документ

Excel предлагает нам 2 основные опции для вставки файлов в книгу:

  • Добавить новый объект (вкладка Новый);
  • Добавить существующий файл (вкладка Из файла).

А также возможность отображения файла в виде значка и создания связи с файлом. Давайте поподробнее остановимся на каждом из имеющихся вариантов.

Создание нового документа

Остаемся в текущей вкладке Новый и в зависимости от наших задач в поле Тип объекта выбираем подходящий тип файла (из наиболее используемых типов тут присутствуют документы Microsoft Word и PowerPoint), далее нажимаем OK и в текущей книге Excel встроенный окном появится новый документ.

К примеру, если выбрать тип файла Microsoft Word, то в окне Excel появится встроенное окно с Word, где доступны все функции программы и мы можем начать набирать любой текст:

Добавлен новый документ

Аналогичный пример при работе с Microsoft PowerPoint:

Добавлен новый документ

Если нам нужно, чтобы внедряемый документ вставлялся не как рабочее окно программы, а более компактно, то внешний вид отображения файла можно поменять на отображение с помощью иконки.

В этом случае при создании нового документа поставьте флажок напротив поля В виде значка, далее выберите вид отображаемой иконки с помощью кнопки Сменить значок (вид меняется в зависимости от программы внедряемого файла), либо оставьте текущий вариант иконки, а также в случае необходимости поменяйте подпись:

Добавлен новый документ

В результате в рабочем окне Excel появится изображение выбранной иконки и по двойному щелчку мыши по иконке будет открываться исходный документ:

Добавлен новый документ

Теперь перейдем ко второму варианту вставки документа.

Внедрение существующего файла

Помимо создания нового документа мы можем добавить уже готовый существующий файл. В этом случае вверху начального окна с настройками выбираем вкладку Из файла:

Добавлен новый документ

Далее для добавления файла нажимаем кнопку Обзор и вставляем нужный нам файл (как и в предыдущем случае мы дополнительно можем задать значок):

Добавлен новый документ

Еще одной важной особенностью при вставке документа является возможность связать вставляемый файл с исходным документом, для этого нужно поставить галочку напротив поля Связь с файлом.

В этом случае при внесении каких-либо изменений в исходный файл эти изменения отобразятся в прикреплённом файле. Однако, обратите внимание, что связь будет работать только в том случае, если у конечного пользователя (который работает с файлом) будет доступ к этому файлу.

Другими словами, если внедряемый файл сохранен в общем доступе, то связь будет работать, если же файл сохранить в локальном месте, куда нет доступа у читателя, то каждый раз будет открываться первоначальная версия файла.

На этом все!

Спасибо за внимание!
Если у вас остались вопросы по теме статьи — делитесь своими мыслями в х.

Удачи вам и до скорых встреч на страницах блога TutorExcel.Ru!

Ввод на основании в 1С программно

Рассмотрим простой пример программного ввода документа в 1С на основании. Допустим необходимо после проведения приходного документа «Приход» создать расходный документ «Расход» на основании данных полученных из приходного документа.

Простое создание на основании стандартным способом платформы 1С

  • В документе «Расход» или «Приход» нужно настроить связь на вкладке «Ввод на основании»:
  • Добавлен новый документ
  • Где указать с кем он связан:
  • Добавлен новый документ
  • Должна получиться следующая картина:
  • Добавлен новый документ

Если вы только начинаете программировать в 1С или просто хотите систематизировать свои знания — попробуйте Школу программирования 1С нашего друга Владимира Милькина. Пошаговые и понятные уроки даже для новичка с поддержкой учителя. Попробуйте бесплатно по ссылке >>

Далее в модуле документа «Расход» нужно создать процедуру «Обработка заполнения» с помощью клика в верхнем меню:

Добавлен новый документ

Если в документе уже существуют данная процедура — нужно не создавать новую, а добавлять код в существующую процедуру.

И прописать программный код заполнения. Пример кода:

//Код из модуля объекта документа «Расход». Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)                       Если ТипЗнч(ДанныеЗаполнения) = Тип(«ДокументСсылка.Приход») Тогда                                               Склад = ДанныеЗаполнения.Склад;                         Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл                                    НоваяСтрока = Товары.Добавить();                                    НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;                                    //… заполняем другие реквизиты табличной части                         КонецЦикла;                                   КонецЕсли; КонецПроцедуры

Программный код можно также создать автоматически для этого нужно воспользоваться «Конструктором ввода на основания».

Конструктор ввода на основании

  1. Чтобы в 1С автоматически создать процедуру, нужно нажать на кнопку «Конструктор ввода на основании»:
  2. Добавлен новый документ
  3. Где с помощью функции «Заполнить выражения» можно автоматически сопоставить название реквизитов:
  4. Добавлен новый документ

Если реквизиты различаются по названию, их можно сопоставить вручную. Например, в одной табличной части у вас реквизит «Номенклатура», а в другой «Товар».

После нажатия на «Ок», 1С сама сформирует готовый программный код:

Добавлен новый документ

Внимание! Конструктор нельзя использовать, если процедура заполнения уже существует — вы потеряете существующий программный код.

Создание документа после записи первого документа с последующей записью созданного

Для реализации такой задачи можно использовать метод объекта Заполнить(), в параметры которого необходимо будет передать данные заполнения из документа прихода.  Метод инициирует событие ОбработкаЗаполнения() и вызов процедуры-обработчика в модуле объекта документа «Расход».

Пример кода:

//Код из модуля формы документа «Приход». &НаСервере Процедура ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи)                   //Создаём новый документ             НовДокумент = Документы.Расход.СоздатьДокумент();             //Заполняем созданный документ (реквизиты документа заполняются значениями, которые совпадают по именам реквизитов)             НовДокумент.Заполнить(ТекущийОбъект.Ссылка);             //Записываем созданный документ             НовДокумент.Записать(РежимЗаписиДокумента.Проведение,РежимПроведенияДокумента.Оперативный);           КонецПроцедуры //Код из модуля объекта документа «Расход». Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)                       Если ТипЗнч(ДанныеЗаполнения) = Тип(«ДокументСсылка.Приход») Тогда                                               Склад = ДанныеЗаполнения.Склад;                         Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл                                    НоваяСтрока = Товары.Добавить();                                    НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;                                    //… заполняем другие реквизиты табличной части                         КонецЦикла;                                   КонецЕсли; КонецПроцедуры

Читайте также:  Удостоверение тракториста-машиниста. Получение, замена, лишение прав тракториста-машиниста.

Создание объекта  после записи с открытием управляемой формы

Для программного создания документа в 1С с открытием управляемой формы пользователю можно использовать функцию ОткрытьФорму(), в параметры которой можно передавать данные для заполнения.

Пример кода:

//Код из модуля формы документа «Приход». &НаКлиенте Процедура ПослеЗаписи(ПараметрыЗаписи) //Создаём структуру для передачи в виде параметра при открытии формы. ПараметрыФормы = Новый Структура(«Основание», Объект.Ссылка); //Открываем форму документа расход с передачей данных для заполнения ОткрытьФорму(«Документ.Расход.ФормаОбъекта», ПараметрыФормы); КонецПроцедуры //Код из модуля объекта документа «Расход». Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка) Если ТипЗнч(ДанныеЗаполнения) = Тип(«ДокументСсылка.Приход») Тогда Склад = ДанныеЗаполнения.Склад; Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл НоваяСтрока = Товары.Добавить(); НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура; // … заполняем другие реквизиты табличной части КонецЦикла; КонецЕсли; КонецПроцедуры

К сожалению, мы физически не можем проконсультировать бесплатно всех желающих, но наша команда будет рада оказать услуги по внедрению и обслуживанию 1С. Более подробно о наших услугах можно узнать на странице Услуги 1С или просто позвоните по телефону +7 (499) 350 29 00. Мы работаем в Москве и области.

Остались вопросы?

СПРОСИТЕ в х!

4 способа добавления нового листа в Excel

Часто пользователям, работающим в табличном редакторе Эксель, необходимо добавить новый рабочий лист в табличный документ.

Безусловно, можно создать новый документ, но этот вариант целесообразно использовать только в тех случаях, когда нет необходимости в связывании разнообразной информации между собой.

В программе имеется несколько методов, позволяющих выполнить добавление листа в документ табличного редактора. Рассмотрим все способы более детально.

Кнопка «Новый лист» табличного процессора Эксель

Этот метод считается наиболее простым и удобным в применении. Его использует большая часть пользователей табличного редактора. Высокая распространенность способа объясняется тем, что алгоритм добавления нового рабочего листа очень прост и понятен даже начинающих пользователям.

Необходимо нажать ЛКМ на специальный элемент под названием «Новый лист», располагающийся правее от уже существующих рабочих листов в нижней части табличного процессора. Сама кнопка имеет вид небольшого плюсика темного оттенка. Наименование новому, только что созданному рабочему листу присваивается автоматически. Название листа можно отредактировать.

Добавлен новый документ1

Подробная инструкция по редактированию названия выглядит следующим образом:

  1. Два раза кликаем ЛКМ по созданному рабочему листу.
  2. Вводим то наименование, которое хотим дать.
  3. После проведения всех манипуляций щелкаем на кнопку «Enter», располагающуюся на клавиатуре.

Добавлен новый документ2

  1. Готово! Название нового рабочего листа изменилось.

Применение специального контекстного меню Эксель

Контекстное меню позволяет за несколько быстрых шагов реализовать процедуру добавления нового рабочего листа в табличный документ. Подробная инструкция по добавлению выглядит так:

  1. Смотрим в нижнюю часть интерфейса табличного процессора и находим один из имеющихся листов документа.
  2. Кликаем по нему ПКМ.
  3. На экране отобразилось небольшое контекстное меню. Находим элемент под названием «Вставить лист» и жмем по нему ЛКМ.

Добавлен новый документ3

  1. Готово! Мы добавили новый рабочий лист в документ.

Можно заметить, что этот метод, позволяющий добавить лист в документ при помощи контекстного меню, так же легок в применении, как и раннее рассмотренный способ. Рабочему листу, добавленному этим методом, можно аналогичным образом отредактировать название.

Обратите внимание!  При помощи контекстного меню можно не только вставить новый рабочий лист, но также и удалить существующие.

Подробная инструкция по удалению рабочего листа выглядит следующим образом:

  1. Находим один из имеющихся листов документа.
  2. Кликаем по листу правой клавишей мышки.
  3. На экране появилось маленькое контекстное меню. Находим элемент под названием «Удалить», жмем по нему левой кнопкой мышки.
  4. Готово! Мы удалили рабочий лист из документа.

Используя контекстное меню можно также переименовать, переместить, скопировать и защитить рабочий лист.

Добавление рабочего листа при помощи ленты инструментов

Добавить новый рабочий лист в документ табличного процессора Эксель можно, используя специальную многофункциональную ленту инструментов, располагающуюся в верхней части интерфейса. Подробная инструкция выглядит следующим образом:

  1. Первоначально перемещаемся в раздел «Главная». В правой части ленты инструментов находим элемент под названием «Ячейки» и жмем левой кнопкой мыши на значок стрелки, располагающийся рядом с ним. Раскрылся перечень из трех кнопок «Вставить», «Удалить» и «Формат». Жмем левой кнопкой мыши на еще одну стрелку, находящуюся около кнопки «Вставить».

Добавлен новый документ4

  1. Раскрылся еще один небольшой список из четырех элементов. Нам необходим самый последний элемент под названием «Вставить лист». Щёлкаем по нему ЛКМ.

Добавлен новый документ5

  1. Готово! Мы реализовали процедуру добавления нового рабочего листа в табличный документ. Стоит заметить, что, как и в ранее рассмотренных способах, можно отредактировать наименование созданного рабочего листа, а также удалить его.

Важно! Если окошко табличного процессора раскрыто в полном размере, то пропадает необходимость искать элемент «Ячейки». В этом случае кнопка «Вставить лист», находящаяся в раскрывающемся перечне элемента «Вставить», располагается сразу же в разделе под названием «Главная».

Добавлен новый документ6

Использование горячих клавиш табличного процессора

В табличном процессоре Эксель существуют собственные специальные горячие клавиши, применение которых позволяет значительно уменьшить время на нахождение необходимых инструментов в меню программы.

Для добавления нового рабочего листа в табличный документ необходимо просто осуществить нажатие комбинации клавиш «Shift+F11» на клавиатуре. После добавления нового рабочего листа этим способом, мы сразу же окажемся в его рабочей области. После того, как новый рабочий лист добавится в книгу, его наименование можно будет отредактировать вышерассмотренным способом.

Заключение

Процедура добавления нового рабочего листа в документ Эксель – это простая операция, являющаяся одной из наиболее распространенных и часто применяемых пользователями табличного процессора.

Если пользователь не умеет осуществлять выполнение этой процедуры, то он не сможет эффективно и качественно реализовать свою работу.

Умение добавлять новый рабочий лист в книгу – это базовый навык, которым должен обладать каждый пользователь, желающий быстро и правильно работать в табличном процессоре.

Оцените качество статьи. Нам важно ваше мнение:

Создание нового документа в Microsoft Word. Шаблоны документов

Перед тем, как начать работу в Microsoft Word, вам нужно научиться создавать новые документы. Процесс довольно прост. С нашей инструкцией вы разберетесь очень быстро.

Оглавление:

Использование горячих клавиш

Как вы знаете, горячие клавиши существенно позволяют ускорить работу за компьютером. Так и в Microsoft Word, основные операции можно осуществить, нажав соответствующее сочетание клавиш.

  • Если нам нужно создать чистый документ, без форматирования, полностью готовый к работе, нам следует нажать:
  • Ctrl+N
  • Делать это нужно, при запущенном редакторе.

Вам пригодится: здесь представлены все основные сочетания горячих клавиш Word

Используем меню редактора

Запустите Microsoft Word. В левом верхнем углу щелкните кнопу «Файл». Выберите пункт «Создать». Откроется меню, со всеми доступными шаблонами. Вам нужен пункт «Новый документ». Выберите его, и нажмите кнопку «Создать».

Читайте также:  Использование ГЛОНАСС при самостоятельном оформлении ДТП с 1 октября 2019 года

Добавлен новый документ

Документ будет создан, вы увидите чистый лист без форматирования. Теперь с ним можно работать.

Контекстное меню Windows

Если на вашем компьютере установлен пакет программ Microsoft Office, то функции создания новых документов встроены в контекстное меню Windows.

Перейдите в ту папку, в которой вы хотите расположить будущий документ. Вызовите контекстное меню, нажатием правой кнопкой мыши на любое свободное место папки. В появившемся меню выберите пункт «Создать», затем «Документ Microsoft Word». Он будет создан.

Добавлен новый документ

Давайте теперь зададим для него его имя. Выделяем и снова вызываем контекстное меню. Теперь нажимаем пункт «Переименовать». Набирайте нужное значение, и щелкайте «Enter».

Теперь запускайте его, и можно работать.

Создание шаблона документа

Если вы часто работаете с документами, которые имеют схожую структуру, то есть смысл создать для них шаблон.

Шаблон Word — базовая структура документа, которая включает в себя расположение отдельных элементов, настройки форматирования текста. Пример шаблона — официальное письмо. Логотип компании сверху по центру, сбоку информация о директоре и тд.

Каждый раз, когда вам нужно будет написать письмо своим клиентам, достаточно создать новый документ, на основе готового шаблона, и добавить нужный текст.

Итак, как можно создать новый шаблон в Word. Запускайте редактор, и создавайте новый документ. Оформляйте его соответствующим образом. Добавьте все необходимые элементы и графику. После того, как это будет закончено, переходите в меню «Файл», и щелкайте кнопку «Сохранить как». В открывшемся окне выберите тип файла «Шаблоны Word», и место расположения шаблона. Нажмите кнопку «Сохранить».

  1. Добавлен новый документ
  2. Теперь когда вам нужно будет его открыть, просто выберите шаблон в списке.
  3. Добавлен новый документ
  4. Видео к статье:

Заключение

Используйте нашу инструкцию, чтобы создать новый документ Word. Функция шаблонов пригодится вам, если в работе вы часто используйте однотипные документы.

Наши рекомендации

Хотите узнать, как делать сноски? Тогда читайте наши руководства.

В прошлом материале мы рассказали о том, как сделать альбомный лист в Word.

Создание гиперссылки в Word позволит сделать документ более интерактивным.

Стоит почитать

Зачем искать информацию на других сайтах, если все собрано у нас?

Программист 1C — 1C. Добавляем новый документ в типовую конфигурацию, получаем две кнопки Создать на основании. Как убрать лишнюю

Нехитрое дело – добавить в типовую конфигурацию, например «1С ERP Управление предприятием 2», новый документ (назовём его «Запрос цен») и настроить его так, чтобы он создавался на основании типового документа, скажем «Заказ материалов в производство».

Однако, подводные камни всё-таки обнаруживаются. На форме документа «Заказ материалов в производство» появилось две кнопки «Создать на основании». Одна типовая, на рисунке она слева, а другая образовалась после добавления нового документа.

При нажатии этой кнопки появляется список из единственного, вновь добавленного документа. Если же нажать штатную кнопку, то открывается список из нескольких типовых документов, среди которых, увы, нет нашего, добавленного.

Возникает логичное желание перенести команду создания нового документа из правой кнопки в левую.

Добавлен новый документ

Для того, чтобы перенести команду в список штатной кнопки сделаем следующее:

В модуле менеджера документа «Заказ материалов в производство» есть процедура ДобавитьКомандыСозданияНаОсновании. Добавим в неё вызов функции, которую позже напишем в модуле менеджера документа «Запрос цен».

Документы.ЗапросЦен.ДобавитьКомандуСоздатьНаОснованииЗаказаКлиента(КомандыСоздатьНаОсновании);

Добавляем функцию в модуль менеджера документа «Запрос цен»:

// Заполняет список команд создания на основании. Функция ДобавитьКомандуСоздатьНаОснованииЗаказаКлиента(КомандыСоздатьНаОсновании) Экспорт Если ПравоДоступа(«Добавление», Метаданные.Документы.ЗапросЦен) Тогда КомандаСоздатьНаОсновании = КомандыСоздатьНаОсновании.Добавить(); КомандаСоздатьНаОсновании.Обработчик = «дкВводНаОснованииКлиент.ЗапросЦенСоздатьНаОснованииЗаказа»; КомандаСоздатьНаОсновании.Идентификатор = «ЗапросЦенСоздатьНаОснованииЗаказа»; КомандаСоздатьНаОсновании.Представление = НСтр(«ru = 'Запрос цен'»); КомандаСоздатьНаОсновании.ПроверкаПроведенияПередСозданиемНаОсновании = Истина; Возврат КомандаСоздатьНаОсновании; КонецЕсли; Возврат Неопределено; КонецФункции

В этой функции мы указали обработчик, расположенный в общем модуле дкВводНаОснованииКлиент. В типовой конфигурации подобные обработчики находятся в общем модуле ВводНаОснованииКлиент, но чтобы не изменять штатный модуль, был создан другой, с префиксом.

В общем модуле дкВводНаОснованииКлиент создаём функцию обработчика, которая откроет нам форму создаваемого документа:

Функция ЗапросЦенСоздатьНаОснованииЗаказа(ОписаниеКоманды) Экспорт ПараметрыВыполненияКоманды = Новый Структура(«Источник,Уникальность,Окно,НавигационнаяСсылка»); ЗаполнитьЗначенияСвойств(ПараметрыВыполненияКоманды, ОписаниеКоманды.ДополнительныеПараметры); // Основание — документ, на основании которого формируется документ «Запрос цен». Основание = ОписаниеКоманды.ОбъектыОснований[0]; ПараметрыОткрытия = Новый Структура; ПараметрыОткрытия.Вставить(«Основание»,Основание); Если ПараметрыОткрытия Неопределено Тогда ОткрытьФорму( «Документ.ЗапросЦен.Форма.ФормаДокумента», ПараметрыОткрытия, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка); КонецЕсли; КонецФункции

Таким образом мы добавили наш документ в список штатной кнопки «Создать на основании». Осталось убрать лишнюю кнопку на форме документа «Заказ материалов в производства». Делается это в форме документа «Заказ материалов в производство» в левом верхнем фрейме, на вкладке «Командный интерфейс». Снимаем флаги «Видимость» и «Автовидимость» для документа «Запрос цен».

Добавлен новый документ

Теперь в форме заказа материалов порядок.

Урок 24. Документы: создание формы, добавление реквизитов на формы

Всем привет. Продолжаем изучать документ.

Сегодня мы поработаем с формой документа: научимся ее создавать и добавлять на нее новые реквизиты.

Откроем документ «ПриходДенежныхСредств» и добавим реквизит «Договор» (Рисунок 1).

Рисунок 1 — Реквизит «Договор»

Рисунок 1 — Реквизит «Договор»

Укажем у реквизита «Договор» ссылку на справочник «Договоры» (Рисунок 1).

Теперь зайдем в пользователя и проверим изменения (Рисунок 2)!

Рисунок 2 — выпадающий список для поля «Договор»

Рисунок 2 — выпадающий список для поля «Договор»

Теперь я хочу сделать таким образом, что бы при выборе контрагента «Поставщик 3» показывались только те договоры, которые относятся к этому контрагенту! У нас для этого уже есть заготовки и просто необходимо включить этот функционал.

До этого мы указывали, что справочник «Договоры» является подчиненным для справочника «Контрагенты» — является владельцем.

Посмотрите на рисунок 2, сейчас в этом окне показываются все договоры, которые относятся к этому контрагенту и которые не относятся, а мне необходимо лишние отфильтровать по владельцу (контрагенту).

Для этого нужно открыть свойства реквизита «Договор» и найти свойство «Связи параметров выбора» (Рисунок 3).

Рисунок 3 — Свойства реквизита

Рисунок 3 — Свойства реквизита

У этого свойства необходимо нажать на значок многоточия и откроется окно (Рисунок 4).

Рисунок 4 — Выбор реквизита для отбора

Рисунок 4 — Выбор реквизита для отбора

В этом окне нам необходимо перетащить реквизит, по которому будет делаться отбор — это Контрагент. Нужно выделить реквизит и нажать на значок стрелки вправо и он переместится в правое окно (Рисунок 5).

Рисунок 5 — Отбор по владельцу

Рисунок 5 — Отбор по владельцу

В правом окне необходимо установить значения, которые показаны на рисунке 5 и нажать «Ок».

Если поле (столбец) «Имя» не отображается как на рисунке, то необходимо по нему дважды щелкнуть и в выпадающем списке выбрать необходимое значение.

Читайте также:  Изменения ПДД с 18 марта 2018 года

После этого нужно перейти в режим пользователя и проверить изменения (Рисунок 6).

Рисунок 6 — Отфильтрованные договоры

Рисунок 6 — Отфильтрованные договоры

На рисунке 6 видно, что реквизит сам добавился и на форму документа и на форму списка, а так же, отбор по владельцу работает.

Работает это так: как только вы выбрали в поле «Контрагент» какой-то элемент, так сразу для поля «Договор» срабатывает отбор и будет показываться только то, что относится к этому владельцу (контрагенту).

Давайте продолжим.

Добавим реквизит «Договор» (Рисунок 8) в документ «РасходДенег» — он будет абсолютно таким же, как и в прошлом документе, то есть нужно в свойствах указать отбор по владельцу (если не помните как, то посмотрите выше, там это описано), но перед этим добавим форму документа на вкладке «Формы» (Рисунок 7), выберите необходимые реквизиты, которые будут отображаться на форме и нажмите «Готово».

Рисунок 7 — Форма документа

Рисунок 7 — Форма документа

Закройте форму, она пока нам не нужна и теперь перейдите на вкладку «Данные» и создадим реквизит «Договор» (Рисунок 8).

Рисунок 8 — Реквизит «Договор»

Рисунок 8 — Реквизит «Договор»

После этого запустить пользователя и проверить изменения (Рисунок 9).

Рисунок 9 — Форма документа

Рисунок 9 — Форма документа

Посмотрите на рисунок 9, на форме документа нет реквизита «Договор»! Как так и почему? Ведь мы же его создали, а он тут не отображается!

Но, если закрыть форму документа и посмотреть на форму списка (Рисунок 10), то мы увидим, что этот реквизит на этой форме есть!

Рисунок 10 — Форма списка

Рисунок 10 — Форма списка

Как так получается? Почему в одном месте его нет, а в другом есть?

Все очень просто, все точно так же как и в справочнике! Мы создали реквизит после того, как создали форму! А в этом случае платформа понимает: «как только создана форма, она уходит в сторону и все работу по добавлению чего-то нового на форму, отдает полностью пользователю»!

Мы создали форму документа, а потом только создали реквизит. Именно поэтому он не добавился на форму, так как нам нужно добавлять его на форму вручную, а форму списка мы не трогали и именно поэтому платформа сама его добавила!

Давайте добавим реквизит на форму! Для этого откроем объект на вкладке «Формы» и откроем форму документа (Рисунок 11).

Рисунок 11 — Форма документа

Рисунок 11 — Форма документа

Теперь необходимо в правой части окна раскрыть список «Объект» и там найти реквизит «Договор» (Договор 12).

Рисунок 12 — Перемещение реквизита на форму

Рисунок 12 — Перемещение реквизита на форму

Проверим изменения в пользовательском режиме (Рисунок 13).

Рисунок 13 — Реквизит на форме

Рисунок 13 — Реквизит на форме

Все так и работает: как только создаете какую-то форму, так сразу платформа перестает сама добавлять реквизиты на форму, но если вы до создания формы создали все реквизиты и потом создали форму, то автоматически все реквизиты появятся на форме!!!

Мало того, что реквизит появился на форме, так и отбор работает — показываются только те договоры, которые относятся к определенному контрагенту!

Давайте теперь добавим новую табличную часть «Дополнительно» в документ «Расход денег» (Рисунок 14) и будет только один реквизит «Сообщение» с типом — строка, длиной — неограниченно.

Рисунок 14 — Новая табличная часть

Рисунок 14 — Новая табличная часть

Теперь проверим изменения в пользователе и убедимся в том, что она не появилась на форме документа — значит, нужно переместить ее сначала на форму в режиме разработчика (Рисунок 15).

Рисунок 15 — Перемещение таблицы

Рисунок 15 — Перемещение таблицы

Теперь проверим пользователя и будет выглядеть вот так (Рисунок 16).

Рисунок 16 — Таблица на форме

Рисунок 16 — Таблица на форме

Как видим по рисунку 16, табличка появилась выше первых двух таблиц, а не стала после таблички «Услуги» как на рисунке 17.

Рисунок 17 — Таблицы друг за другом

Рисунок 17 — Таблицы друг за другом

  • Так, как на рисунке 16, программа тоже будет работать, но не удобно будет, слишком много места занимает одна таблица, а нужно так, как на рисунке 17 — для экономии места и удобности.
  • Для этого перейдем на форму в режиме разработчика и сделаем следующее:
  • 1. Рисунок 18 — выделить группу «Страницы» на форме

Рисунок 18 — Выбор руппы

Рисунок 18 — Выбор руппы

2. Рисунок 19 — Правой кнопкой мыши или через плюсик добавить новую группу (папку) в группу «Страницы». Выбрать «Страница»

Рисунок 19 — Создание группы

Рисунок 19 — Создание группы

3. Рисунок 20 — Переименовать новую группу (Имя и Синоним)

Рисунок 20 — Переименование группы

Рисунок 20 — Переименование группы

4. Рисунок 21 — Переместить в папку «Дополнительно» таблицу «Дополнительно»

Рисунок 21 — перемещение таблицы в группу

Рисунок 21 — перемещение таблицы в группу

5. Рисунок 22 — Запустить пользователя и проверить изменения .

Рисунок 22 — Отображение таблицы в пользовательском режиме

Рисунок 22 — Отображение таблицы в пользовательском режиме

Теперь место сэкономлено, стало более удобнее работать!

При добавлении таблички в нужно место мы познакомились побольше с формой, а именно с созданием группировки (папки), которая помогает правильно отобразить элемент на форме. Более подробно с созданием группировки мы поработаем на следующем занятии и разберемся со всем.

На этом статья урока подходит к концу. Попробуйте выполнить все действия, которые описаны в этом уроке. Если что-то не получается, то вы всегда сможете написать вопрос о том. что вам непонятно или вернуться к предыдущим урокам и посмотреть их — ссылки внизу!

Всем спасибо. Задать вопросы, которые у вас возникли вы можете, написав комментарий или вступить в группу и задать там свой вопрос. Ссылка для вступления в группу — t.me.Apiscourses

Подписаться в группу ВКонтакте

Или написать на электронную почту — awesome.razrab@yandex.ru

Прошлые уроки:

Введение Урок 1 Урок 2 Урок 3 Урок 4 Урок 5 Урок 6 Урок 7 Урок 8 Урок 9 Урок 10 Урок 11 Урок 12 Урок 13 Урок 14 Урок 15 Урок 16 Урок 17 Урок 18 Урок 19 Урок 20 Урок 21 Урок 22 Урок 23

На этом все. Жду Вас на следующем занятии.

P.S. Подписывайтесь на мой канал 🙂

Оставьте комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Adblock
detector